Sie sind hier:

Tipps & Tricks zu Excel

Neue Funktionen Mittelwertwenn, Mittelwertwenns

- Version 2010 -

In Excel 2010 gibt es zusätzlich zu der Funktion MITTELWERT die Funktionen MITTELWERTWENN und MITTELWERTWENNS.

Die Abbildung zeigt Beträge, die auf den entsprechenden Finanzpositionen gebucht wurden. Die Funktion MITTELWERT berechnet den Durchschnitt aus allen Beträgen, z. B. =MITTELWERT(B2:B35). Das Ergebnis der Funktion ist in Zelle E2 zu sehen.

Abbildung zur Mittelwertfunktion, JPG, 72.2 KB

Mit der Funktion MITTELWERTWENN können Sie den Durchschnittsbetrag auf bestimmte Beträge einschränken. Z. B. auf alle Beträge, die auf der Finanzposition 3550.51100-1 gebucht wurden.

Die Funktion ist folgendermaßen aufgebaut: Quickinfo zur Mittelwertwenn-Funktion

  • Bereich sind die Zellen A2 bis A35. Dies ist der Suchbereich.
  • Hier wird eine Übereinstimmung mit dem Kriterium 3550.51100-1 gesucht. In der Abbildung steht in Zelle D3 der Wert 3550.51100-1. Die Formel bezieht sich in diesem Fall auf diese Zelle. Sie können das Kriterium 3550.51100-1 auch direkt in die Formel eintragen.
  • Als letztes markieren Sie die Zellen B2 bis B35. Dies ist der Bereich aus dem der Mittelwert gebildet werden soll.

Sie können auch einen Durchschnitt aus allen Beträgen bilden, die unter 100 € liegen. Diese Zahl wird z. B. in Zelle D6 eingetragen. Die Funktion ist folgendermaßen aufgebaut: =MITTELWERTWENN(B2:B35;"

  • Im Unterschied zu der Funktion oben, ist der Suchbereich identisch mit dem Bereich, aus dem der Mittelwert gebildet werden soll. Das erste Mal ist B2 bis B35 der Suchbereich für alle Beträge unter 100 €.
  • Sie müssen das Zeichen für Kleiner (

Sie können statt des Zellbezugs auch den Wert direkt eingeben: =MITTELWERTWENN(B2:B35;"

Alternative Nutzung MittelwertwennFunktion, JPG, 59.1 KB

Die Funktion MITTELWERTWENNS ermöglicht weitere Kriterien. Beispielsweise wollen Sie den Durchschnitt aller Beträge unter 100 € berechnen. Zusätzlich sollen alle 0 €-Beträge nicht mit in den Durchschnitt einfließen. Die Funktion ist folgendermaßen aufgebaut: MITTELWERTWENNS(B2:B35;B2:B35;"0")

  • Der erste Bereich enthält die Werte, aus denen der Durchschnitt gebildet werden soll. In dieser Funktion steht der Mittelwertbereich an erster Stelle. Erst dann kommt der Suchbereich. In der Funktion Mittelwertwenn ist es genau anders herum.
  • Nach dem Mittelwertbereich und dem ersten Suchbereich kommt das Kriterium "
  • Es folgt der nächste Suchbereich und das nächste Kriterium "0".

In diesem Beispiel ist es immer derselbe Suchbereich (B2 bis B35). Es können aber auch unterschiedliche Suchbereiche sein. Dazu das folgende Beispiel:

Sie wollen einen Mittelwert für den Monat Januar bilden. Aber nur für die Haushaltsstellen 51101-0 und 51101-1. Zusätzlich sollen nur Beträge über 0 € einfließen. Die Formel hierfür lautet:

=MITTELWERTWENNS(E2:E231;B2:B231;"51101-0";B2:B231;"51101-0";E2:E231;">0")

Mittelwertwennsfuntkion, JPG, 40.6 KB